NSClient++ Help (#1) - Not all checks are received by NSCA (#761) - Message List

Not all checks are received by NSCA

Hello,

I just wanted to ask about a bug I am facing on most of my hosts, using NSClient only with NSCA. This bug has been described in : http://nsclient.org/nscp/discussion/message/2064 http://nsclient.org/nscp/discussion/topic/618

Maybe this one : http://nsclient.org/nscp/ticket/406 And this one : http://www.nsclient.org/nscp/ticket/338

I tried everything, but could not make it work in a stable way on all my hosts. My problem : On some hosts, I have got about 20 checks sent to NSCA every 5 minutes, and everything will be all right. On some hosts, these checks will not be all sent to NSCA.

This is not always the same checks. This is not always a fixed number of checks This is not always a fixed amount of character which will be send.

This is the tests that I launched, maybe it could help you to help me :)

  • On my laptop, I have been able to configure NSClient with 32 checks, each sending 500 character of results, every 1 minute. And everything was alright.
  • Another host was only sending 12 over 16 checks, I tried to install the latest nightly build (0.3.9.285 2011-02-16). And it began to send 14/16 checks (maybe a coincidence related to a restart of NSClient ?)
  • I tried this same nightly build on another host, nothing changed (11/17 checks only were sent)

After that, I tried to launch the tests described in : http://nsclient.org/nscp/discussion/topic/618 (NG-TC-W2K3-BASE_1 to NG-TC-W2K3-BASE_199)

  • With the 0.3.8 stable release, I received only 150 to 180 checks.
  • With the latest 0.3.9, I received about the same.
  • With the latest 0.3.9, with the option "chunk=10", I received only about 80 checks --> NSClient seemed to send 4 to 5 checks by connection with the NSCA server ?

And finally, just to be sure, I launched a wireshark on my laptop, to see if NSClient was really sending results : Even is NSClient said in its log that results had been sent, I had the proof that they were never sent over the network... On the other side, every check that was really sent over the networks was received by the NSCA server.

Right now, I don't what I can test to give you more information.

Maybe you could point me to a version of NSClient where this has already been corrected ? But like I said, latest nightly build did not help me...

Maybe you are working on it in the 0.4.x version ?

Do you want some more information ?

Thanks in advance

P.S : Sorry for my english...

  • Message #2150

    as found in this thread : http://nsclient.org/nscp/discussion/message/2064#2064

    there is a problem when the time of the client is greater than the server's time increasing the time by one minute resolves the problem. the latest release 0.3.8 and nightly build are affected

    A quick fix would be to schedule an ntpdate followed by this command : date --set='+1 minutes'

    i hope this problem will be corrected soon

    Regards

    Massimo

    • Message #2183

      In addition to this there is option to set the "time difference" between the server and the client if they are not the same (for some strange reason)

      Also not that there have been a lot of issues fixed in the latest RC:s regarding this... So please upgrade if you have issues and let me know...

      Michael Medin

Subscriptions