NSClient++ Help (#1) - Windows 2003 Server R2 SP2 will not accept connections (#179) - Message List

Windows 2003 Server R2 SP2 will not accept connections

I'm trying to install NSClient++ version 0.3.3 on a Window 2003 Server x64 machine. Having set the ini file up, I can telnet in from localhost correctly, but from any other host I can't connect to the service, with a "Connection Failed" message almost instantly.

With NSClient++ running in test mode I get a message in the window each time I connect with telnet, but for any other connections I get no message at all, not even a refused connection message.

This happens whether I connect from another host, or from the same machine using it's actual IP address, e.g. telnet 12489 doesn't work but telnet localhost 12489 does, when sitting at the machine who's address is

Windows firewall is on, with an exception specified for port 12489, but turning it off makes no difference.

  • Message #494

    Can you post your ini file ... I am having some troubles as well .. I keep getting no data received .. I was able to telnet to windows server on ports 12489 and 5666 .. so it is accepting connections

    • Message #497

      best way tofigure this out is a. make sure that nsclient++ is "working".

      1. run: nsclient++ /test
      2. telnet in on the port you se and make sure you see an entry on the console.

      then try the same from the server, and then with check_nt.

      the client logs which ports it binds to when it starts so you can see there what ports it is using.


      • Message #502

        Thanks for the reply. NSClient++ is binding to, which I presume is right. Telnet in on port 12489 works if I use localhost as the host name, and fails if I use the client machine's IP address. It also doesn't work telneting from the server or using check_nt. When it fails I get a message from windows telnet: Connecting to not open connection to the host, on port 12489: Connect failed.

        No messages whatsoever appear on the nsclient++ console at the time, where as when I connect to localhost an Invalid Password message is produced.

        • Message #503

          then it is safe to guess that it is a network problem.

          Try checking windows firewall and/or third party firewalls that might block your way.


        • Message #504

          IIRC w2k3 had a pretty locked down firewall out-of-the-box?


          • Message #508

            It turned out that windows IP filtering was enabled on the machine - about 5 levels of dialogue down from TCP/IP properties of the network adaptor (where you set the IP address etc) there is an Advanced TCP/IP properties dialogue where you can configure which ports are available to external connections, in the same sort of manner as /etc/hosts.allow on *nix (except you can't do it on a host-by-host basis, only port numbers). Someone had neatly configure this to only allow web traffic in, hence why I couldn't get through to NSCP.

            Having unblocked that it's working fine now. Thanks!