Please notice that forums and news and documentation have moved elsewhere.

Opened 4 years ago

Closed 3 years ago

#378 closed defect (fixed)

NSClient++ fails on Intel Xeon Processor

Reported by: priyadarsan.sahu Owned by: mickem
Priority: 1 Milestone: 0.4.0
Component: installer Version: 0.3.7
Severity: Bugs Keywords:
Cc: priyadarsan.sahu

Description

Hi,

I am trying to install NSClient 3.7 and 3.8 on 64 bit win 2003 on a intel xeon processor based server. Hoever it fails with a error this processor type does not support.

Is there any solution or patches available. Kindly assist.

Thanks and regards
Priyadarsan

Attachments (1)

log1.txt (24.7 KB) - added by priyadarsan.sahu 4 years ago.
Installation_log

Download all attachments as: .zip

Change History (8)

comment:1 Changed 4 years ago by mickem

  • Resolution set to wontfix
  • Status changed from new to closed

Do you by xeon mean itanium?

IA64 (which is what the plattform in that case is called) requires a very expensive version of Visual Studio which I can afford. So you can compile it your self if you have the compiler. Or you could donate "Visual Studio 2005 Team Suite" or you can use the very very old 0.3.1 or something like that which has a itanium build.

Sorry.

Michael Medin

comment:2 Changed 4 years ago by priyadarsan.sahu

  • Cc priyadarsan.sahu added
  • Priority changed from 5 to 1
  • Resolution wontfix deleted
  • Status changed from closed to reopened
  • Version set to 0.3.7

Hi Michael,

Thanks a ton for your reply.

Xeon is x86-64 architecture different from Itanium (IA-64). The http://nsclient.org/nscp/downloads privies NSClient++-0.3.7-x64.msi, but it fails to install on Windows Server 2003 64-bit with the following error:

"This installation package is not supported by this processor type. Please contact your Product vendor"

I get the below error when i try to install from the zipped package on command prompt.

"The image file E:\Nagios_120510\NSClient++.exe is valid, but is for a machine type other than the current machine."

Regards,
Priyadarsan.

comment:3 Changed 4 years ago by mickem

Could you do a logged install?

msiexec /l* log.txt /i <MSI>

And send me the log michael (AT) medin (DOT) name.

If you get a "invalid binary" my guess would be it is no x86 or x64. x64 should be able to run 32 bit X86 binaries as well.

One option in this case could be that it is a 32 bit x86 which is somehow not detected correctly by the installer. So could you also please try the both the zipped x64 and x64 versions?

Michael Medin

comment:4 Changed 4 years ago by priyadarsan.sahu

Hi Michael,

The first problem i wrote is solved. I was wrongly trying to install a 64 bit NSC package on a 32 bit machine. After i used 32bit msi i was able to install it. Now the problem is i am not able to install 64 bit MSI on a 64 bit machine. It ends with a premature error. Here i am attaching the log file for your reference. However i tried to install manually and it works.

Thank you a lot

Best Regards,
Priyadarsan.

Changed 4 years ago by priyadarsan.sahu

Installation_log

comment:5 Changed 3 years ago by mickem

  • Milestone set to 0.4.0

comment:6 Changed 3 years ago by mickem

  • Component changed from CheckSystem to installer

comment:7 Changed 3 years ago by mickem

  • Resolution set to fixed
  • Status changed from reopened to closed

This should be allowed in next RC

Note: See TracTickets for help on using tickets.